Configuration Guide Vol. 3


5.2.4 VRF Configuration Settings [SL-L3A]

Points to note

In this configuration, DHCP or BOOTP servers are prepared for each VRF.

Figure 5-3: VRF configuration

[Figure Data]

Command examples

  1. (config)# vlan 2

    (config-vlan)# exit

    (config)# interface gigabitethernet 1/0/5

    (config-if)# switchport mode access

    (config-if)# switchport access vlan 2

    (config-if)# exit

    (config)# vrf definition 2

    (config-vrf)# exit

    (config)# interface vlan 2

    (config-if)# vrf forwarding 2

    (config-if)# ip address 10.1.0.1 255.255.0.0

    (config-if)# exit

    Sets the VLAN ID, line, access port, VRF, VLAN interface, VRF ID, and IP address in advance.

  2. (config)# vlan 3

    (config-vlan)# exit

    (config)# interface gigabitethernet 1/0/7

    (config-if)# switchport mode access

    (config-if)# switchport access vlan 3

    (config-if)# exit

    (config)# interface vlan 3

    (config-if)# vrf forwarding 2

    (config-if)# ip address 10.20.0.1 255.255.0.0

    (config-if)# exit

    As in step 1, sets the VLAN ID, line, access port, VRF ID, and IP address for the interface from which packets are forwarded to the DHCP or BOOTP server.

  3. (config)# vlan 4

    (config-vlan)# exit

    (config)# interface gigabitethernet 1/0/9

    (config-if)# switchport mode access

    (config-if)# switchport access vlan 4

    (config-if)# exit

    (config)# vrf definition 3

    (config-vrf)# exit

    (config)# interface vlan 4

    (config-if)# vrf forwarding 3

    (config-if)# ip address 10.2.0.1 255.255.0.0

    (config-if)# exit

    (config)# vlan 5

    (config-vlan)# exit

    (config)# interface gigabitethernet 1/0/11

    (config-if)# switchport mode access

    (config-if)# switchport access vlan 5

    (config-if)# exit

    (config)# interface vlan 5

    (config-if)# vrf forwarding 3

    (config-if)# ip address 10.20.0.1 255.255.0.0

    (config-if)# exit

    As in steps 1 and 2, sets the VLAN ID, line, access port, VRF, VRF ID, and IP address for each interface on the VRF ID 3 side.

  4. (config)# interface vlan 2

    (config-if)# ip helper-address 10.20.0.10

    Sets IP address of VRF ID 2's DHCP/BOOTP server as the helper address.

  5. (config)# interface vlan 4

    (config-if)# ip helper-address 10.20.0.10

    Sets the IP address of the DHCP or BOOTP server on the VRF ID 3 side as the helper address (since the VRF ID differs from the VLAN ID 2, the forwarding destination helper address is treated as another destination).