Configuration Guide Vol. 3


5.2.5 Extranet Configuration Settings [SL-L3A]

Points to note

Sets exchange routing between VRFs in an extranet configuration.

Figure 5-4: Extranet configuration

[Figure Data]

Command examples

  1. (config)# vlan 2

    (config-vlan)# exit

    (config)# interface gigabitethernet 1/0/5

    (config-if)# switchport mode access

    (config-if)# switchport access vlan 2

    (config-if)# exit

    (config)# vrf definition 2

    (config-vrf)# exit

    (config)# interface vlan 2

    (config-if)# vrf forwarding 2

    (config-if)# ip address 10.1.0.1 255.255.0.0

    (config-if)# exit

    Sets the VLAN ID, line, access port, VRF, VLAN interface, VRF ID, and IP address in advance.

  2. (config)# vlan 4

    (config-vlan)# exit

    (config)# interface gigabitethernet 1/0/1

    (config-if)# switchport mode access

    (config-if)# switchport access vlan 4

    (config-if)# exit

    (config)# vrf definition 4

    (config-vrf)# exit

    (config)# interface vlan 4

    (config-if)# vrf forwarding 4

    (config-if)# ip address 10.20.0.1 255.255.0.0

    (config-if)# exit

    Sets the VLAN ID, line, access port, VRF, VRF ID, and IP address for the interface from which packets are forwarded to the DHCP or BOOTP server.

  3. (config)# vlan 3

    (config-vlan)# exit

    (config)# interface gigabitethernet 1/0/7

    (config-if)# switchport mode access

    (config-if)# switchport access vlan 3

    (config-if)# exit

    (config)# vrf definition 3

    (config-vrf)# exit

    (config)# interface vlan 3

    (config-if)# vrf forwarding 3

    (config-if)# ip address 10.2.0.1 255.255.0.0

    (config-if)# exit

    As in step 1, sets the VLAN ID, line, access port, VRF, VRF ID, and IP address for the interface on the VRF ID 3 side.

  4. (config)# route-map VRF4PERMIT permit 10

    (config-route-map)# match vrf 4

    (config-route-map)# exit

    (config)# vrf definition 2

    (config-vrf)# import inter-vrf VRF4PERMIT

    (config-vrf)# exit

    (config)# vrf definition 3

    (config-vrf)# import inter-vrf VRF4PERMIT

    (config-vrf)# exit

    Creates a filter that permits the VRF ID 4 route to use the VRF ID 4 route in VRF IDs 2 and 3.

  5. (config)# route-map VRF2AND3PERMIT permit 10

    (config-route-map)# match vrf 2 3

    (config-route-map)# exit

    (config)# vrf definition 4

    (config-vrf)# import inter-vrf VRF2AND3PERMIT

    (config-vrf)# exit

    Creates a filter that permits the routes of VRF IDs 2 and 3 to use the routes in VRF ID 4.

  6. (config)# interface vlan 2

    (config-if)# ip helper-address 10.20.0.10

    Sets the IP address of the DHCP or BOOTP server on the VRF ID 4 side as the helper address.

  7. (config)# interface vlan 3

    (config-if)# ip helper-address 10.20.0.10

    Sets the IP address of the DHCP or BOOTP server on the VRF ID 4 side as the helper address.