Configuration Guide Vol. 3


5.2.3 Settings in a multihomed configuration

Points to note

In a multihomed configuration, the primary IP address is usually used as the IP address of the input interface.However, you can use the ip relay-agent-address command to assign a secondary IP address as the IP address of the input interface.

In the following example, networks B and C do not run DHCP or BOOTP.

Figure 5-2: Multihomed configuration

[Figure Data]

Command examples

  1. (config)# vlan 2

    (config-vlan)# exit

    (config)# interface gigabitethernet 1/0/5

    (config-if)# switchport mode access

    (config-if)# switchport access vlan 2

    (config-if)# exit

    Sets the VLAN ID, line, and access port in advance.

  2. (config)# interface vlan 2

    (config-if)# ip address 11.1.0.1 255.255.0.0

    (config-if)# ip address 10.1.0.1 255.255.0.0 secondary

    (config-if)# ip address 12.1.0.1 255.255.0.0 secondary

    (config-if)# exit

    Sets the IP address of network B as the primary IP address, and the IP addresses of networks A and C as secondary IP addresses.

  3. (config)# vlan 3

    (config-vlan)# exit

    (config)# interface gigabitethernet 1/0/7

    (config-if)# switchport mode access

    (config-if)# switchport access vlan 3

    (config-if)# exit

    (config)# interface vlan 3

    (config-if)# ip address 20.1.0.1 255.255.0.0

    (config-if)# exit

    Similar to steps 1 and 2, sets the VLAN ID, line, access port, and IP address for the interface from which packets are forwarded to the DHCP or BOOTP server.

  4. (config)# interface vlan 2

    (config-if)# ip helper-address 20.1.0.10

    Sets the IP address of the DHCP or BOOTP server as the helper address.

  5. (config-if)# ip relay-agent-address 10.1.0.1

    (config-if)# exit

    Sets the IP address of network A as the address of the relay agent.

Notes

If you omit the ip relay-agent-address command, the address of the relay agent is the primary IP address assigned to the applicable interface.