Configuration Guide Vol. 3


5.2.2 Settings in Basic Configuration

Points to note

The example below shows how to, on the DHCP relay agent, set the helper address, which is the address of the destination to which BOOTP request packets are forwarded.

Figure 5-1: Basic configuration (when there is one relay agent between DHCP/BOOTP server and DHCP/BOOTP client)

[Figure Data]

Command examples

  1. (config)# vlan 2

    (config-vlan)# exit

    (config)# interface gigabitethernet 1/0/5

    (config-if)# switchport mode access

    (config-if)# switchport access vlan 2

    (config-if)# exit

    (config)# interface vlan 2

    (config-if)# ip address 10.1.0.1 255.255.0.0

    (config-if)# exit

    Sets the VLAN ID, line, access port, VLAN interface, and IP address in advance.

  2. (config)# vlan 3

    (config-vlan)# exit

    (config)# interface gigabitethernet 1/0/7

    (config-if)# switchport mode access

    (config-if)# switchport access vlan 3

    (config-if)# exit

    (config)# interface vlan 3

    (config-if)# ip address 20.1.0.1 255.255.0.0

    (config-if)# exit

    Similar to step 1, sets the VLAN ID, line, access port, and IP address for the interface from which packets are forwarded to the DHCP or BOOTP server.

  3. (config)# interface vlan 2

    (config-if)# ip helper-address 20.1.0.10

    (config-if)# exit

    Sets the IP address of the DHCP or BOOTP server as the helper address.