コマンドモード一覧
コマンドモードの一覧を,次の表に示します。
項番 |
コマンドモードごとのプロンプト表示 |
コマンドモード説明 |
モード移行コマンド |
---|---|---|---|
1 |
(config) |
グローバルコンフィグレーションモード |
# enable # configure |
2 |
(config-line) |
リモートログインやコンソールの設定 |
(config)# line vty (config)# line console |
3 |
(config-if) |
マネージメントポートの設定 |
(config)# interface mgmt |
イーサネットインタフェースの設定 |
(config)# interface gigabitethernet (config)# interface tengigabitethernet (config)# interface fortygigabitethernet (config)# interface hundredgigabitethernet |
||
ポートチャネルインタフェースの設定 |
(config)# interface port-channel |
||
VLANインタフェースの設定 |
(config)# interface vlan |
||
VXLANインタフェースの設定【SL-L3A】 |
(config)# interface vxlan |
||
ループバックインタフェースの設定 |
(config)# interface loopback |
||
Nullインタフェースの設定 |
(config)# interface null |
||
4 |
(config-if-range) |
イーサネットインタフェースの複数設定 |
(config)# interface range gigabitethernet (config)# interface range tengigabitethernet (config)# interface range fortygigabitethernet (config)# interface range hundredgigabitethernet |
ポートチャネルインタフェースの複数設定 |
(config)# interface range port-channel |
||
VLANインタフェースの複数設定 |
(config)# interface range vlan |
||
5 |
(config-subif) |
イーサネットサブインタフェースの設定【SL-L3A】 |
(config)# interface gigabitethernet (config)# interface tengigabitethernet (config)# interface fortygigabitethernet (config)# interface hundredgigabitethernet (サブインタフェースインデックス指定時) |
ポートチャネルサブインタフェースの設定【SL-L3A】 |
(config)# interface port-channel (サブインタフェースインデックス指定時) |
||
6 |
(config-vlan) |
VLAN設定 |
(config)# vlan |
7 |
(config-mst) |
マルチプルスパニングツリーの設定 |
(config)# spanning-tree mst configuration |
8 |
(config-axrp) |
Ring Protocolの設定 |
(config)# axrp |
9 |
(config-gsrp) |
GSRPの設定 |
(config)# gsrp |
10 |
(config-ext-nacl) |
IPv4パケットフィルタの設定 |
(config)# ip access-list extended |
11 |
(config-std-nacl) |
IPv4アドレスフィルタの設定 |
(config)# ip access-list standard |
12 |
(config-ipv6-acl) |
IPv6フィルタの設定 |
(config)# ipv6 access-list |
13 |
(config-ext-macl) |
MACフィルタの設定 |
(config)# mac access-list extended |
14 |
(config-ip-qos) |
IPv4 QoSの設定 |
(config)# ip qos-flow-list |
15 |
(config-ipv6-qos) |
IPv6 QoSの設定 |
(config)# ipv6 qos-flow-list |
16 |
(config-mac-qos) |
MAC QoSの設定 |
(config)# mac qos-flow-list |
17 |
(dhcp-config) |
DHCPの設定 |
(config)# ip dhcp pool |
18 |
(config-dhcp) |
IPv6 DHCP(PD)の設定 |
(config)# ipv6 dhcp pool |
19 |
(config-route-map) |
ルートマップの設定 |
(config)# route-map |
20 |
(config-rtr-rip) |
RIPngの設定 |
(config)# ipv6 router rip |
21 |
(config-router) |
RIPの設定 |
(config)# router rip |
OSPFの設定 |
(config)# router ospf |
||
BGP4/BGP4+の設定 |
(config)# router bgp |
||
22 |
(config-rtr) |
OSPFv3の設定 |
(config)# ipv6 router ospf |
23 |
(config-router-af) |
RIPのVRF単位の設定 |
(config)# router rip (config-router)# address-family ipv4 vrf |
BGP4のVRF単位の設定 (config-router-af)(ipv4 vrf)モード |
(config)# router bgp (config-router)# address-family ipv4 vrf |
||
BGP4+のグローバルネットワークの設定 (config-router-af)(ipv6)モード |
(config)# router bgp (config-router)# address-family ipv6 |
||
BGP4+のVRF単位の設定 (config-router-af)(ipv6 vrf)モード |
(config)# router bgp (config-router)# address-family ipv6 vrf |
||
24 |
(config-auto-cf) |
auto-configの設定 |
(config)# auto-config |
25 |
(config-netconf) |
netconfの設定 |
(config)# netconf |
26 |
(config-view) |
viewの設定 |
(config)# parser view |
27 |
(config-ether-cfm) |
ドメイン名称とMAの設定 |
(config)# ethernet cfm domain |
28 |
(config-track-object) |
ポリシーベースルーティングのトラッキング機能の設定 |
(config)# track-object |
29 |
(config-pol) |
ポリシーベースルーティングリスト情報の設定 |
(config)# policy-list |
30 |
(config-dest-mirror) |
ポリシーベースミラーリングのミラーポートの設定 |
(config)# destination-interface-list |
31 |
(config-bfd) |
BFDの設定 |
(config)# bfd name |