Configuration Guide Vol. 1


21.2.4 Configuring port channel Interfaces

A port channel interface is used to set the functions that operate on a channel group.

A port channel interface is set up manually by using configuration commands or generated automatically when the channel-group mode command is executed in Ethernet interface configuration mode.

<Structure of this section>

(1) Relationship between Port Channel Interface and Ethernet Interface

A port channel interface is used to configure the functionality that operates on a channel group. The same functionality can also be configured from the Ethernet interface in configuration mode. Some of the commands provided by these interfaces are related as follows:

The following table describes the port channel interface commands whose settings must be identical with the settings of the related Ethernet interface commands.

Table 21-4: Commands related to port channel interfaces

Functionality

Command

VLAN

switchport mode

switchport access

switchport trunk

switchport protocol

switchport mac

switchport vlan mapping

switchport vlan mapping enable

Spanning Tree Protocols

spanning-tree portfast

spanning-tree bpdufilter

spanning-tree bpduguard

spanning-tree guard

spanning-tree link-type

spanning-tree port-priority

spanning-tree cost

spanning-tree vlan port-priority

spanning-tree vlan cost

spanning-tree single port-priority

spanning-tree single cost

spanning-tree mst port-priority

spanning-tree mst cost

IEEE802.1X

dot1x port-control

dot1x force-authorize-port

dot1x multiple-hosts

dot1x multiple-authentication

dot1x max-supplicant

dot1x reauthentication

dot1x timeout reauth-period

dot1x timeout tx-period

dot1x timeout supp-timeout

dot1x timeout server-timeout

dot1x timeout keep-unauth

dot1x timeout quiet-period

dot1x max-req

dot1x ignore-eapol-start

dot1x supplicant-detection

DHCP Snooping

ip dhcp snooping trust

ip arp inspection trust

ip verify source

GSRP

gsrp direct-link

gsrp reset-flush-port

gsrp no-flush-port

gsrp exception-port

L2 Loop Detection

loop-detection

OADP

oadp enable

(2) Settings for functions that operate on channel groups

Points to note

The port channel interface is used to set up the VLAN, Spanning Tree Protocols, and other functionality used for channel group operations. In this example, you set up a trunk port.

Command examples

  1. (config)# interface range gigabitethernet 1/0/1-2

    (config-if-range)# channel-group 10 mode on

    (config-if-range)# exit

    Adds ports 1/0/1 and 1/0/2 to channel group 10 in static mode. The port channel interface for channel group 10 is automatically generated.

  2. (config)# interface port-channel 10

    Switches channel group 10 to port channel interface configuration mode.

  3. (config-if)# switchport mode trunk

    Sets channel group 10 as a trunk port.

(3) Port Channel Interface shutdown

Points to note

When shutdown is set for a port channel interface, communication over all ports registered in the channel group stops. Ports in the link-up status stop communication, preserving the status.

Command examples

  1. (config)# interface range gigabitethernet 1/0/1-2

    (config-if-range)# channel-group 10 mode on

    (config-if-range)# exit

    Adds ports 1/0/1 and 1/0/2 to channel group 10 in static mode.

  2. (config)# interface port-channel 10

    (config-if)# shutdown

    Changes the mode to port channel interface configuration mode, and sets shutdown. Channel group 10 is shut down, so communication over ports 1/0/1 and 1/0/2 stops.