14.2.1 List of configuration commands
The following table lists the commands used to configure route filtering.
Command name |
Description |
---|---|
distribute-list in (BGP4) |
Filters which BGP4-learned routes are added to the routing table. |
distribute-list in (OSPF) |
Filters which OSPF-learned routes are added to the routing table. |
distribute-list in (RIP) |
Filters which RIP-learned routes are added to the routing table. |
distribute-list out (BGP4) |
Filters which BGP4 routes are advertised. |
distribute-list out (OSPF) |
Filters which OSPF routes are advertised. |
distribute-list out (RIP) |
Filters which RIP routes are advertised. |
ip as-path access-list |
Configures access-list to filter routes based on their AS_PATH attribute. |
ip community-list |
Configures a community list to filter routes based on their COMMUNITIES attribute. |
ip prefix-list |
Configures an IPv4 prefix list. |
match as-path |
Configures route-map to use the AS_PATH attribute as filter conditions. |
match community |
Configures route-map to use the COMMUNITIES attribute as filter conditions. |
match interface |
Configures route-map to use the interface of the route as filter conditions. |
match ip address |
Configures route-map to use the IPv4 address prefix as filter conditions. |
match ip route-source |
Configures route-map to use the source IPv4 address as filter conditions. |
match origin |
Configures route-map to use the ORIGIN attribute as filter conditions. |
match protocol |
Configures route-map to use the routing protocol as filter conditions. |
match route-type |
Configures route-map to use the route type as filter conditions. |
match tag |
Configures route-map to use the tag value as filter conditions. |
match vrf |
Configures route-map to use a VRF as filter conditions. |
neighbor in (BGP4) |
Specifies the filter to be used for BGP4 learned route filtering. |
neighbor out (BGP4) |
Sets the filters used for BGP4 advertised route filtering. |
redistribute (BGP4) |
Sets the protocol types of routes advertised from BGP4. |
redistribute (OSPF) |
Sets the protocol types of routes advertised from OSPF. |
redistribute (RIP) |
Sets the protocol types of routes advertised from RIP. |
route-map |
Configures route-map. |
set as-path prepend count |
Sets the number of AS_PATH numbers added to the routing information. |
set community |
Replaces the COMMUNITIES attribute of the route. |
set community-delete |
Deletes the COMMUNITIES attribute of the route. |
set distance |
Sets the priority of the routing information. |
set local-preference |
Sets the LOCAL_PREF attribute of the routing information. |
set metric |
Assigns a metric to the routing information. |
set metric-type |
Sets the metric type or metric of the routing information. |
set origin |
Sets the ORIGIN attribute of the routing information. |
set tag |
Sets the tag value of the routing information. |
access-list #1 |
Sets an access list used as an IPv4 filter. |
deny (ip access-list extended) #1 |
Specifies the conditions by which the IPv4 packet filter denies access. |
deny (ip access-list standard) #1 |
Specifies the conditions by which the IPv4 address filter denies access. |
ip access-list extended #1 |
Sets an access list used as an IPv4 packet filter. |
ip access-list resequence #1 |
Re-sequences the sequence numbers that determine the order in which the IPv4 address filter and IPv4 packet filter apply filter conditions. |
ip access-list standard #1 |
Configures an access list to serve as an IPv4 address filter. |
permit (ip access-list extended) #1 |
Specifies the conditions by which the IPv4 packet filter permits access. |
permit (ip access-list standard) #1 |
Specifies the conditions by which the IPv4 address filter permits access. |
router rip #2 |
Configures router settings related to the RIP routing protocol. |
router ospf #3 |
Configures router settings related to the OSPF routing protocol. |
router bgp #4 |
Configures router settings related to the BGP (BGP4 and BGP4+) routing protocol. |
import inter-vrf #5 |
Controls routes that are imported from another VRF or the global network according to the filter. |
- Note #1
-
See Configuration Command Reference Vol.1" "25 Access List.
- Note #2
-
See "Configuration Command Reference Vol.2" "12 RIP".
- Note #3
-
See "Configuration Command Reference Vol.2" "13 OSPF".
- Note #4
-
See "Configuration Command Reference Vol.2" "14 BGP4".
- Note #5
-
See "Configuration Command Reference Vol.2" "32 VRF".